Anmeldeprobleme per SVN+SSH an einem SVN Repository mit Subclipse beheben

Heute mal ein kurzer Tipp zur Verwendung von Subclipse in Verbindung mit einem SVN Repository. Ich habe für ein paar kleine Projekte SVN Repositories aufgesetzt und setze dabei zur Verbindung der Clients mit dem Repository auf das svn+ssh Protokoll zur Absicherung der Verbindung.

Dabei ist heute ein Problem aufgetaucht, für dass ich zuerst keine Lösung finden konnte. Ich habe einen Benutzer angelegt und anschließend ein SVN Repository mit svnadmin erstellt. Den Benutzer habe ich zu einer Gruppe hinzugefügt und dieser Gruppe die entsprechenden Rechte am Repository gegeben. Soweit so gut. Aber beim Versuch das Repository mit Subclipse in Eclipse einzubinden scheiterte dann das Anmelden per SSH.

Ich konnte allerdings von einem anderen Server per Konsole und mit svn+ssh auf das Repository zugreifen. Meine Vermutung war also, dass etwas mit dem Benutzer nicht stimmen muss. Und ich kam dann auch auf die Lösung. Mein Passwort enthielt einige Sonderzeichen als Ersatz für Buchstaben, in etwa so:

S1ch€resP@ssw0rt

Das Problem dabei war das Euro-Zeichen. Dieses ist in zwar im ASCII Zeichensatz enthalten, aber entweder verwendet Subclipse eine andere Zeichenkodierung, oder es unterstützt das Euro-Zeichen schlichtweg nicht. Nachdem ich das Euro-Zeichen durch ein anderes Symbol ersetzt habe, konnte ich mich auch mit Subclipse an meinem SVN Repository per svn+ssh verbinden.

Ich hoffe, ich konnte dem ein oder anderen mit diesem Tipp weiterhelfen, da es bestimmt nicht selten vorkommt, dass man im europäischen Raum ein “E” mit dem “€”-Zeichen ersetzt um ein Passwort etwas sicherer zu machen. Falls ihr auch einen tollen Tipp zu Subversion habt würde ich mich über einen Kommentar wie immer freuen

Veröffentlicht von

Bernhard ist fest angestellter Webentwickler, entwickelt in seiner Freizeit Plugin, schreibt in seinem Blog über WordPress und andere Themen, treibt sich gerne bei den WP Meetups in Berlin und Potsdam herum und läuft nach Feierabend den ein oder anderen Halbmarathon.

2 Kommentare » Schreibe einen Kommentar

  1. Hi,

    ich hatte ein ähnliches Problem. In unserem Unternehmen findet die SVN-Authentifizierung über die Domänenkennung statt. Dort hatte ich ein Passwort mit Umlaut “ü” gewählt. Das konnte SVN nicht verarbeiten und ein Login war unmöglich.

    Es wird allerhöchste(!!!!!!!) Zeit, dass moderne Software auch moderne Zeichensätze unterstützt!

    • Ja das Problem mit Sonderzeichen in Passwörtern kenne ich leider auch zur Genüge. Nicht einmal der ASCII-Zeichensatz ist bei manchen Systemen enthalten. So musste ich z.B. für mein NAS ein anderes Passwort als für meinen Laptop wählen, wodurch ich nun ständig das Passwort eintippen muss, da es nicht automatisch übernommen wird. Also heuzutage sollte UFT8 wirklich überall Standard sein!

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.